Beveiligingsproblemen maken Linux op Azure kwetsbaar

16-09-2021 | door: Redactie

Beveiligingsproblemen maken Linux op Azure kwetsbaar

Vier kwetsbaarheden maken het mogelijk om gevaarlijke code uit te voeren in virtuele Linux machines op Azure. Het probleem zit bij een dienst die automatisch en stiekem wordt uitgerold.

Cloudbedrijf Wiz zegt dat het recent vier kwetsbaarheden ontdekte rond OMI (Open Management Interface), een dienst die regelmatig wordt gebruikt bij het opzetten van virtuele machines op Linux in Microsoft Azure. Daarmee is het mogelijk om root privileges te krijgen en zo code uit te voeren. Dat maakt het onder meer mogelijk om ransomware uit te rollen.

Patch

Wiz meldde de kwetsbaarheden aan Microsoft en ze werden sinds gisteren, 14 september, gepatcht. Maar het bedrijf raadt klanten aan om zelf te controleren of hun omgeving effectief de laatste versie van OMI (versie 1.6.8.1) draaien.

De bewuste kwetsbaarheden zijn CVE-2021-38645, CVE-2021-38647, CVE-2021-38648 en CVE-2021-38649. Wiz heeft in een technische blog ook meer details over haar bevindingen.

Stiekem uitgerold

Wat het lastig maakt is dat OMI geen dienst is waar je als Azure-klant bewust voor kiest. De dienst wordt bij een reeks tools automatisch uitgerold.

Wiz zegt dat dat onder meer het geval is bij Azure Automation, Azure Automatic Update, Azure Operations Management Suite (OMS), Azure Log Analytics, Azure Configuration Management en Azure Diagnostics. Maar het kan niet uitsluiten dat OMI ook bij andere diensten wordt uitgerold.

Derde incident op drie weken tijd

Voor Azure het nieuws wel vrij ongelegen. Het is immers de derde keer dat er belangrijke kwetsbaarheden moet worden opgelapt. Vorige week ging het om een niet gepatchte omgeving ontdekt door Palo Alto Networks. Eind augustus ging het om een zwakke plek in de Cosmos DB-database.

In samenwerking met Data News

Terug naar nieuws overzicht

Tags

Cloud, Security
Cloud